Graphics not working properly on Windows8.1 under VMWARE Fusion v8.0 (Macintosh)

stuart masters 8 years ago in Vizex updated 8 years ago 7

Hi there,

I'm new to the Forums so please excuse me if this has been covered before.

I'm running MM2014 (64-bit) on a MacBookPro under WMWARE Fusion 8.0 (although the problems described below also occured under VMWARE Fusion 7.0).

My problems include, but are not limited to:

- I can show the full drillhole traces in the overview window, but if I try it in section (in the main window) the traces do not appear (the hole names and collars will appear though);

- at other times some drillhole features (e.g. text labels) will correctly show on clipped sections but bars for drillholes that are off-section will also be shown on the section (albeit they won't be filled).

I contacted Support about this a few months ago and they kindly looked into it in great detail but still could not explain the problem (and thus offer a solution) but were sure that it was a problem with my graphics setup..

However, I can't recall the problem occuring when I first got the Mac (mid-2014) and I haven't knowingly changed the graphics setup or hardware. What has changed is that I started with VMWARE Fusion 6.0 and (I think) Wiindows 7 Ultimate.

Hence I am asking whether anyone else has experienced, and resolved, this issue?



I've just updated to Windows 10 and guess what - problem "resolved", but the catch is that the resolution is very poor as Windows uses its standard low-res driver (as it claims, falsely, that the current driver isn't compatible with W10). However, when I get the proper driver reinstalled I get back to very high resolution, but the problem returns.

All other graphics on the monitor (i.e. not in Micromine) seem to be OK.


I suspect that the OpenGL graphics drivers provided by VMWare are perhaps buggy and/or don't provide the correct capabilities for Micromine.

What are the OpenGL graphics driver details as detected and reported by Micromine?

You can find detailed information in the MMLog file which is stored the the Micromine Profile folder (File | Explorer | Profile). You can also find a less detailed summary via Tools | Check Graphics Configuration.

It would be handy if you posted information from the W10 low res driver, and the High Res one.

Hi Scott,

Thanks for your reply.

Here's the Tools\Check Graphics output:

There are "known" compatbility issues with "SVGA 3D" on Windows (it's VMWARE issue not isolated to Micromine) but apparently it is compatible but somehow WIndows treats it as incompatible...

Here's the output from the MMLOg150-x64.txt file (this is all of it as I'm not sure which part is relevant):

[0] Micromine 15.0.5 Build 697 x64 Aug 14 2015 09:21:10
[0] 30/10/2015 8:26:51 AM
[0] Crash Quick info: installed
[0] Crash reporting handler installed
[0] Adding Quick Crash Info file: C:\ProgramData\Micromine\MICROMINE\CrashReportFiles\CrashQuickInfo.txt
[0] 960
[0] Touch Found (Ready)(Multi input)(Integrated Touch)
[0] Touch Mode Initialised
[0] DPI 96
[0] 994
[0] 999
[0] 1003
[0] 1009
[0] 1013
[0] 1018
[0] 1024
[0] 1026
[0] 1037
[0] 1042
[0] 1044
[0] 1061
[0] 1063
[0] 1068
[0] 1085
[0] 1125
[0] 1134
[0] 1144
[0] 1250
[0] 1279
[0] 1327
[0] 1333
[0] 1337
[1] 1346
[2] 1366
[2] 1373
[2] 1400
[2] 2405
[2] 1408
[2] 1425
[2] 1443
[2] 1555
[2] 1559
[2] 1592
[2] Mesh JOBOBJECT: Physical memory size 10485223424 bytes (10239476 KB, 9999 MB)
[2] Mesh JOBOBJECT: Setting memory limit to 8912359424 bytes (8703476 KB, 8499 MB)
[2] Mesh JOBOBJECT: Operation result 0
[2] -----------------
DriverVersion :
DriverDate : 2015/07/15
AdapterRAM : 0
DriverName : VMware SVGA 3D
Availability : 3
[2] Colour bits : 32
Depth bits : 24
Stencil bits : 8
[2] composition supported
[2] -- OpenGL information --
GL_VENDOR : VMware, Inc.
GL_VERSION : 3.0 Mesa 10.6.0 (git-beb7765)
GL_RENDERER : Gallium 0.4 on SVGA3D; build: RELEASE; LLVM;
Max Texture Size: 16384
GL Shader Version: 1.30
Stereo Support: false
[2] GL_EXTENSIONS: GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_framebuffer_sRGB GL_ARB_multitexture GL_EXT_framebuffer_sRGB GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_occlusion_query GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_NV_depth_clamp GL_NV_fog_distance GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_NV_primitive_restart GL_ARB_depth_clamp GL_ARB_fragment_program_shadow GL_ARB_half_float_pixel GL_ARB_occlusion_query2 GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_color_buffer_float GL_ARB_pixel_buffer_object GL_ARB_texture_compression_rgtc GL_ARB_texture_float GL_ARB_texture_rectangle GL_EXT_packed_float GL_EXT_pixel_buffer_object GL_EXT_texture_compression_rgtc GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_shared_exponent GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_packed_depth_stencil GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_gpu_program_parameters GL_EXT_texture_array GL_EXT_texture_integer GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_OES_EGL_image GL_ARB_copy_buffer GL_ARB_depth_buffer_float GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_map_buffer_range GL_ARB_texture_rg GL_ARB_texture_swizzle GL_ARB_vertex_array_bgra GL_EXT_texture_swizzle GL_EXT_vertex_array_bgra GL_NV_conditional_render GL_AMD_conservative_depth GL_ARB_ES2_compatibility GL_ARB_blend_func_extended GL_ARB_debug_output GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_conventions GL_ARB_provoking_vertex GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_shader_texture_lod GL_ARB_texture_multisample GL_ARB_texture_rgb10_a2ui GL_ARB_uniform_buffer_object GL_ARB_vertex_type_2_10_10_10_rev GL_EXT_provoking_vertex GL_EXT_texture_snorm GL_MESA_texture_signed_rgba GL_ARB_get_program_binary GL_ARB_robustness GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_timer_query GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_internalformat_query GL_ARB_map_buffer_alignment GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_texture_storage GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_transform_feedback GL_AMD_shader_trinary_minmax GL_ARB_ES3_compatibility GL_ARB_clear_buffer_object GL_ARB_explicit_uniform_location GL_ARB_invalidate_subdata GL_ARB_program_interface_query GL_ARB_texture_query_levels GL_ARB_texture_storage_multisample GL_ARB_vertex_attrib_binding GL_KHR_debug GL_ARB_multi_bind GL_EXT_shader_integer_mix GL_KHR_context_flush_control
[2] no memory info gl extensions found
[2] 1610
[2] 1624
[2] 1627
[2] CMmAdoDbOpenHelper enumerating data connection objects
[3] (OLEDB)
[3] Name=SQLOLEDB,ParseName={0C7FF16C-38E3-11d0-97AB-00C04FC2AD98},Type=01,Description=Microsoft OLE DB Provider for SQL Server
[3] Name=MSDataShape,ParseName={3449A1C8-C56C-11D0-AD72-00C04FC29863},Type=01,Description=MSDataShape
[3] Name=SAS Local Data Provider 9.42,ParseName={4B56E201-04AB-4A9F-844B-41AB671026AC},Type=01,Description=SAS Local Data Provider 9.42
[3] Name=ADsDSOObject,ParseName={549365d0-ec26-11cf-8310-00aa00b505db},Type=01,Description=OLE DB Provider for Microsoft Directory Services
[3] Name=SAS OLAP Data Provider 9.42,ParseName={9B342A31-1309-47E4-A954-ACF42ABD1ED1},Type=03,Description=SAS OLAP Data Provider 9.42
[3] Name=Windows Search Data Source,ParseName={9E175B8B-F52A-11D8-B9A5-505054503030},Type=01,Description=Microsoft OLE DB Provider for Search
[3] Name=SAS IOM Data Provider 9.42,ParseName={A6764915-3C79-4FFF-8A65-0A5A6DEAF613},Type=01,Description=SAS IOM Data Provider 9.42
[3] Name=MSDASQL,ParseName={c8b522cb-5cf3-11ce-ade5-00aa0044773d},Type=01,Description=Microsoft OLE DB Provider for ODBC Drivers
[3] Name=MSDASQL Enumerator,ParseName={c8b522cd-5cf3-11ce-ade5-00aa0044773d},Type=02,Description=Microsoft OLE DB Enumerator for ODBC Drivers
[3] Name=SQLOLEDB Enumerator,ParseName={DFA22B8E-E68D-11d0-97E4-00C04FC2AD98},Type=02,Description=Microsoft OLE DB Enumerator for SQL Server
[3] Name=MSDAOSP,ParseName={dfc8bdc0-e378-11d0-9b30-0080c7e9fe95},Type=01,Description=Microsoft OLE DB Simple Provider
[3] Name=SAS SHARE Data Provider 9.42,ParseName={E70DBFDF-E99D-47A6-9B37-8AD484041385},Type=01,Description=SAS SHARE Data Provider 9.42
[3] * No Jet provider available - that's ok, will use ACE instead
[3] * No ACE provider found
[3] (END OLE)
[3] (ODBC)
[3] ODBC Driver name=SQL Server
[3] ODBC Driver name=MM15.0 SQLite3 ODBC Driver
[3] * Using MM flavoured SQLite3 ODBC driver: MM15.0 SQLite3 ODBC Driver
[3] * No XLS ODBC driver found - will use XLSX or XL instead
[3] * No XLSX ODBC driver found - will use XL instead
[3] * No generic Excel ODBC driver found
[3] (END ODBC)
[3] 1631
[3] 1637
[3] 3472
[3] 3542
[3] 3557
[3] 3601
[3] 2385
[3] Colour bits : 32
Depth bits : 24
Stencil bits : 8
[3] composition supported
[3] VMware, Inc. Gallium 0.4 on SVGA3D; build: RELEASE; LLVM; 3.0 Mesa 10.6.0 (git-beb7765)
[3] 3638
[3] 3507
[30] 1709
[30] 1714
[32] Building OpenGL shader: WSDistanceText
[32] Shader Compile Successful: 10027
[32] Shader Compile Successful: 10028
[32] Shader Link Successful: WSDistanceText
[32] Shader build succeeded: WSDistanceText
[35] Colour bits : 32
Depth bits : 24
Stencil bits : 8
[35] composition supported

[35] VMware, Inc. Gallium 0.4 on SVGA3D; build: RELEASE; LLVM; 3.0 Mesa 10.6.0 (git-beb7765)

Here's some example output to explain the problem:

First image shows a cross-sectional view and an overview of 5 planned drill holes with no clipping:

Second image shows a cross-sectional view and an overview of 5 planned drill holes with +/-50m window:

- note that the DH Traces don't show

Finally, I can't find the W10 low-res driver without uninstalling WMWARE Tools etc. and I'd rather not go through that again if at all possible:).

However, I remember it was named something like Microsoft Basic Display Adapter. Unfortunately I didn't make any screen shots of the sections above using this adapter but it looked like it worked, albeit at very low resolution (1152 x something).

The high-res adapter I refer to is the VMWARE SVGA, which is causing me the grief.

So I have the option of high resolution but partial content or low resolution and full content.

Surely I am not the only person who uses MM under VMWARE on a Mac so it'd be useful to hear from any other Amc users out there to see what configuration and adapters they are using.

Thankfully I have my old DELL Laptop so I can keep on working on projects but i'd like to retire it and stick to the MacBookPro if I could :).



I've just noticed that if I use a Trace thickness of <0.30mm then the trace displays, anything thicker and it doesn't show.

This sounds like the OpenGL driver does not like line thickness greater than 1.

I also suspect it is also not hardware accelerated.

You can try the built in Micromine OpenGL Software renderer, this may work better but can be slower and does not support advanced/optimised features in Vizex (like Block Model 3D Shader draw style)

This can be enabled in the mmwin-15.0.ini file, follow these steps:

  1. Find mmwin-15.0.ini in the install folder
  2. copy mmwin-15.0.ini to the Micromine Profile Folder
  3. edit the ini file for the advanced setting you need.

The setting you want to try is:


Micromine does not officially support running in a Virtual Machine as the graphics drivers are often poor quality and/or not hardware accelerated and therefore generally not suitable for a 3D application.

Thanks Scott, I'll give that a go.



That worked :).

Thanks Scott,