Can't edit strings located on the Company's server

Munkhtulga 6 years ago in General updated 6 years ago 5

I am writing this enquiry to solve a difficulty related to Micromine 2016. We are new users of your latest version of Micromine 2016 and have an issue with editing string which is located in the our company’s server. We’re OK with editing any string which located on our personal computers but we cannot unable to activate Edit Lock in the red as shown in the below photo. There are many users of our organization who edit and save same string on the Company server. So therefore, it is critical issue to us. Please note that we were users of Micromine 2014 and downloaded Micromine 2016 recently and activated it. It would be helpful if you reply us as soon as possible. In the below photo, I opened string from the Company server but couldn’t edit it.


Can you please attach a screenshot of what you're talking about? You can use the Insert Image icon:

The Edit Lock in Micromine stops you from being able to edit the data within a form, so if it is turned on you can't edit the string.. I don't know why you're unable to activate it, because all you need to do is select a form and toggle the Edit Lock button.

If Edit Lock isn't the problem, it could be the string file itself. Since Micromine uses the Windows file system, the string file that you want to edit could be either a) designated as read-only, or b) already open by somebody else, which makes it read-only when you try to open it.

I think I may know what Munkhtulga is describing but can you confirm. Are you seeing the edit lock icon next to the string layer when it is loaded in Vizex.


if this is happening all the time then it could be because the Edit lock setting is set to ON for Strings within the Vizex settings under Tools|Options . Please make sure these option is unchecked.

If this option is unchecked and you are using M16.1 then a file will only be locked when loaded if it is already being edited by another user. The way to test this is to copy the file to a local directory and see if it is still locked when you try to work with it.

Just to be clear here there were some changes made in Micromine 2016 that improved the integrity of the data on network projects, but this came at the cost of locking the files more frequently to avoid accidental corruption by simultaneous editing.

Further improvements to this scheme were made to Micromine 2016 Update 1 to allow read access to the file while others are editing. This is now a more seamless solution when working in a collaborative environment - Information messages about the file lock now include details of the user who has the active edit session open which is locking the file.

This is what was listed in the MM2016.1 release notes:

  • Improved concurrent file access; other users are now granted read-only access instead of being locked out of the file

Thanks Guys,

According to the instruction posted by Andrew Esmaili, we have tried unchecking Edit lock in Tool|Options many times but unfortunately it didn't work. I am using M16.1. We had no problem editing string on the Company's server when we used M2014 but we couldn't edit string file which located on the Company's server using M16.1. I am sure that I have tried toggling edit lock button on string even I had to tell other users of Micromine to shut down their computers after that I am the only who opened the string and tried to edit. I thought it may related to our the Server and asked IT guys but they said it was OK. I checked details of string on the Company's server Read only appeared as unchecked. As attached photo, I opened 2 strings; one from the my own computer (in red) and other one from the Company's server (in blue). No problem editing first string but second one I can't do editing.

Thank you all for helping me.